Cisco Packet Tracer 實驗

m0_62588424 2022-01-07 22:46:47 阅读数:746

cisco packet tracer

 

目錄

直接連接兩臺 PC 構建 LAN

用交換機構建 LAN

問題1、2:

問題3:

交換機接口地址列錶

生成樹協議(Spanning Tree Protocol)

路由器配置初步

說明一

說明二

說明三

說明四

說明五

交通大學路由器的初步配置如下:

交通大學路由器基本配置如下:

以太網口:

廣域網口:

重慶大學路由器基本配置如下:

以太網口:

廣域網口:

 

靜態路由

交通大學路由器靜態路由配置:

重慶大學路由器靜態路由配置:

 動態路由 RIP

清除靜態路由配置:

交通大學路由器 RIP 路由配置:

重慶大學路由器 RIP 路由配置: 

動態路由 OSPF

清除 RIP 路由配置:

交通大學路由器 OSPF 路由配置:

重慶大學路由器 OSPF 路由配置: 

基於端口的網絡地址翻譯 PAT

NAT 的實現方式一般有三種:

拓撲圖中各 PC 配置數據如下:

拓撲圖中路由器各接口配置數據如下:

交通大學路由器接口配置如下:

以太網口:

廣域網口:

重慶大學路由器接口配置如下:

以太網口:

 廣域網口:

 交通大學路由器 OSPF 路由配置:

 重慶大學路由器 OSPF 路由配置:

重慶大學路由器丟包的配置:

交通大學路由器 PAT 配置:

虛擬局域網 VLAN

交換機 VLAN 配置:

虛擬局域網管理 VTP

3560 VTP Server 配置:

2960A(左邊) VTP Client 配置:

2960B(右邊) VTP Client 配置:

VLAN 間的通信

3560 交換機配置:

DHCP、DNS及Web服務器簡單配置


直接連接兩臺 PC 構建 LAN

用交換機構建 LAN

問題1、2:

Pc0到pc1以及pc3到pc2成功,其餘的都失敗。

問題3:

所有的線路都成功。

交換機接口地址列錶

生成樹協議(Spanning Tree Protocol)

 

路由器配置初步

 

說明一

交通大學與重慶大學顯然是兩個不同的子網。在不同子網間通信需通過路由器。

路由器的每個接口下至少是一個子網,圖中我們簡單的規劃了 3 個子網:

  1. 左邊路由器是交通大學的,其下使用交換機連接交通大學的網絡,分配網絡號 192.168.1.0/24,該路由器接口也是交通大學網絡的網關,分配 IP 為 192.168.1.1
  2. 右邊路由器是重慶大學的,其下使用交換機連接重慶大學的網絡,分配網絡號 192.168.3.0/24,該路由器接口也是重慶大學網絡的網關,分配 IP 為 192.168.3.1
  3. 兩個路由器之間使用廣域網接口相連,也是一個子網,分配網絡號 192.168.2.0/24

說明二

現實中,交通大學和重慶大學的連接是遠程的。該連接要麼通過路由器的光纖接口,要麼通過廣域網接口即所謂的 serial 口(如拓撲圖所示)進行,一般不會通過雙絞線連接(為什麼?)。

下面我們以通過路由器的廣域網口連接為例來進行相關配置。請注意:我們選用的路由器默認沒有廣域網模塊(名稱為 WIC-1T 等),需要關閉路由器後添加,然後再開機啟動。

說明三

在模擬的廣域網連接中需注意 DCE 和 DTE 端(連線時線路上有提示,帶一個時鐘標志的是 DCE 端。有關 DCE 和 DTE 的概念請查閱相關資料。),在 DCE 端需配置時鐘頻率 64000

說明四

在現實中,對新的路由器,顯然不能遠程進行配置,我們必須在現場通過筆記本的串口與路由器的 console 接口連接並進行初次的配置(注意設置比特率為9600)後,才能通過網絡遠程進行配置。這也是上圖左上畫出筆記本連接的用意。

說明五

在路由器的 CLI 界面中,可看到路由器剛啟動成功後,因為無任何配置,將會提示是否進行對話配置(Would you like to enter the initial configuration dialog?),因其步驟繁多,請選擇 NO

交通大學路由器的初步配置如下:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#line vty 0 4 //可支持0-4共5個終端同時登錄
Router(config-line)#password dswybs // 遠程登錄密碼
Router(config-line)#login
Router(config-line)#exit
Router(config)#enable password dswybs // 特權模式密碼
Router(config)#^Z // 退出
接口名 IP 子網掩碼

交通大學 Router2 以太網口

192.168.1.1

255.255.255.0

交通大學 Router2 廣域網口

192.168.2.1

255.255.255.0

重慶大學 Router3 以太網口

192.168.3.1

255.255.255.0

重慶大學 Router3 廣域網口

192.168.2.2

255.255.255.0

拓撲圖中各 PC 配置數據如下:

節點名

IP

子網掩碼

網關

交通大學 PC0

192.168.1.2

255.255.255.0

192.168.1.1

交通大學 PC1

192.168.1.3

255.255.255.0

192.168.1.1

重慶大學 PC2

192.168.3.2

255.255.255.0

192.168.3.1

重慶大學 PC3

192.168.3.3

255.255.255.0

192.168.3.

交通大學路由器基本配置如下:

以太網口:

Router>enable // 從普通模式進入特權模式
Router#configure terminal // 進入全局配置模式
Router(config)#interface f0/0 // 進入配置以太網口模式
Router(config-if)#ip address 192.168.1.1 255.255.255.0 // 配置該接口的 IP
Router(config-if)#no shutdown // 激活接口
Router(config-if)#^z // 直接退到特權模式
Router#

廣域網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int s0/0 // 進入配置廣域網口模式
Router(config-if)#ip address 192.168.2.1 255.255.255.0 //配置該接口的 IP
Router(config-if)#clock rate 64000 // 其為 DCE 端,配置時鐘頻率
Router(config-if)#no shutdown // 激活接口
Router(config-if)#^z // 直接退到特權模式
Router#

重慶大學路由器基本配置如下:

以太網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int f0/0 // 進入配置以太網口模式
Router(config-if)#ip address 192.168.3.1 255.255.255.0 // 配置該接口的 IP
Router(config-if)#no shutdown // 激活接口
Router(config-if)#^z // 直接退到特權模式
Router#

廣域網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int s0/0 // 進入配置廣域網口模式
Router(config-if)#ip address 192.168.2.2 255.255.255.0 //配置該接口的 IP
Router(config-if)#no shutdown // 激活接口
Router(config-if)#^z // 直接退到特權模式
Router#

 

靜態路由

靜態路由是非自適應性路由協議,是由網絡管理人員手動配置的,不能够根據網絡拓撲的變化而改變。 因此,靜態路由簡單高效,適用於結構非常簡單的網絡。

在當前這個簡單的拓撲結構中我們可以使用靜態路由,即直接告訴路由器到某網絡該怎麼走即可。

在前述路由器基本配置成功的情况下使用以下命令進行靜態路由協議的配置:

交通大學路由器靜態路由配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2 // 告訴交通大學路由器到 192.168.3.0 這個網絡的下一跳是 192.168.2.2
Router(config)#exit //退到特權模式
Router#show ip route //查看路由錶

重慶大學路由器靜態路由配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1 // 告訴重慶大學路由器到 192.168.1.0 這個網絡的下一跳是 192.168.2.1
Router(config)#exit //退到特權模式
Router#show ip route //查看路由錶

查看路由錶你可看到標記為 S 的一條路由,S 錶示 Static 。

至此,這些 PC 能全部相互 ping 通!

 動態路由 RIP

清除靜態路由配置:

  1. 直接關閉路由器電源。相當於沒有保存任何配置,然後各接口再按照前面基本配置所述重新配置 IP 等參數(推薦此方法,可以再熟悉一下接口的配置命令);
  2. 使用 no 命令清除靜態路由。在全局配置模式下,交通大學路由器使用:no ip route 192.168.3.0 255.255.255.0 192.168.2.2,重慶大學路由器使用:no ip route 192.168.1.0 255.255.255.0 192.168.2.1 。相當於使用 no 命令把剛才配置的靜態路由命令給取消。

交通大學路由器 RIP 路由配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#router rip // 啟用 RIP 路由協議,注意是 router 命令
Router(config-router)#network 192.168.1.0 // 網絡 192.168.1.0 與我直連
Router(config-router)#network 192.168.2.0 // 網絡 192.168.2.0 與我直連
Router(config-router)#^z //直接退到特權模式
Router#show ip route //查看路由錶

重慶大學路由器 RIP 路由配置: 

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#router rip // 啟用RIP路由協議,注意是 router 命令
Router(config-router)#network 192.168.3.0 // 網絡 192.168.3.0 與我直連
Router(config-router)#network 192.168.2.0 // 網絡 192.168.2.0 與我直連
Router(config-router)#^z //直接退到特權模式
Router#show ip route //查看路由錶

查看路由錶你可看到標記為 R 的一條路由,R 錶示 RIP 。

至此,這些 PC 也能全部相互 ping 通!

動態路由 OSPF

動態路由協議采用自適應路由算法,能够根據網絡拓撲的變化而重新計算機最佳路由。

RIP 的全稱是 Routing Information Protocol,是距離矢量路由的代錶(目前雖然淘汰,但可作為我們學習的對象)。使用 RIP 協議只需要告訴路由器直接相連有哪些網絡即可,然後 RIP 根據算法自動構建出路由錶。

因為我們模擬的網絡非常簡單,因此不能同時使用靜態和動態路由,否則看不出效果,所以我們需要把剛才配置的靜態路由先清除掉。

清除 RIP 路由配置:

  1. 直接關閉路由器電源。相當於沒有保存任何配置,然後各接口再按照前面基本配置所述重新配置 IP 等參數
  2. 使用 no 命令清除 RIP 路由。在全局配置模式下,各路由器都使用:no router rip 命令進行清除

交通大學路由器 OSPF 路由配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#router ospf 1 // 啟用 OSPF 路由協議,進程號為1(可暫不理會進程號概念)
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0 // 自治域0中的屬於 192.168.1.0/24 網絡的所有主機(反向掩碼)參與 OSPF
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0 // 自治域0中的屬於 192.168.2.0/24 網絡的所有主機(反向掩碼)參與 OSPF
Router(config-router)#^z //直接退到特權模式
Router#show ip route //查看路由錶

重慶大學路由器 OSPF 路由配置: 

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#router ospf 1 // 啟用 OSPF 路由協議,進程號為1
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0 // 自治域0中的屬於 192.168.3.0/24 網絡的所有主機(反向掩碼)參與 OSPF
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0 // 自治域0中的屬於 192.168.2.0/24 網絡的所有主機(反向掩碼)參與 OSPF
Router(config-router)#^z //直接退到特權模式
Router#show ip route //查看路由錶

 

查看路由錶你可看到標記為 O 的一條路由,O 錶示 OSPF 。

至此,這些 PC 能全部相互 ping 通!

基於端口的網絡地址翻譯 PAT

網絡地址轉換(NAT,Network Address Translation)被各個 Internet 服務商即 ISP 廣泛應用於它們的網絡中,也包括 WiFi 網絡。 原因很簡單,NAT 不僅完美地解决了 lP 地址不足的問題,而且還能够有效地避免來自網絡外部的攻擊,隱藏並保護網絡內部的計算機。

NAT 的實現方式一般有三種:

  • 靜態轉換: Static NAT
  • 動態轉換: Dynamic NAT
  • 端口多路複用: OverLoad

端口多路複用使用最多也最靈活。OverLoad 是指不僅改變發向 Internet 數據包的源 IP 地址,同時還改變其源端口,即進行了端口地址轉換(PAT,Port Address Translation)。

采用端口多路複用方式,內部網絡的所有主機均可共享一個合法外部 IP 地址實現對 Internet 的訪問,從而可以最大限度地節約IP地址資源。 同時,又可隱藏網絡內部的所有主機,有效避免來自 Internet 的攻擊。因此,目前網絡中應用最多的就是端口多路複用方式。

我們仍然使用重慶交通大學和重慶大學兩個學校的拓撲進行 PAT 實驗。我們需要保證兩個學校的路由已經配置成功,無論使用靜態路由還是動態路由,以下我們給出完整的配置過程:設定這兩個學校的路由器使用 OSPF 協議,模擬交通大學使用內部 IP 地址(192.168.1.0/24),模擬重慶大學使用外部 IP 地址(8.8.8.0/24),兩個路由器之間使用外部 IP 地址(202.202.240.0/24),在交通大學的出口比特置即廣域網口實施 PAT。

拓撲圖中各 PC 配置數據如下:

節點名

IP

子網掩碼

網關

交通大學 PC0

192.168.1.2

255.255.255.0

192.168.1.1

交通大學 PC1

192.168.1.3

255.255.255.0

192.168.1.1

重慶大學 PC2

8.8.8.2

255.255.255.0

8.8.8.1

重慶大學 PC3

8.8.8.3

255.255.255.0

8.8.8.1

拓撲圖中路由器各接口配置數據如下:

接口名

IP

子網掩碼

交通大學 Router2 以太網口

192.168.1.1

255.255.255.0

交通大學 Router2 廣域網口

202.202.240.1

255.255.255.0

重慶大學 Router3 以太網口

8.8.8.1

255.255.255.0

重慶大學 Router3 廣域網口

202.202.240.2

255.255.255.0

交通大學路由器接口配置如下:

以太網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int f0/0 // 進入配置以太網口模式
Router(config-if)#ip address 192.168.1.1 255.255.255.0 // 配置 IP
Router(config-if)#no shutdown // 激活接口

廣域網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int s0/0 // 進入配置廣域網口模式
Router(config-if)#ip address 202.202.240.1 255.255.255.0 //配置 IP
Router(config-if)#clock rate 64000 // 其為 DCE 端,配置時鐘頻率
Router(config-if)#no shutdown // 激活接口

 

重慶大學路由器接口配置如下:

以太網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int f0/0 // 進入配置以太網口模式
Router(config-if)#ip address 8.8.8.1 255.255.255.0 // 配置 IP
Router(config-if)#no shutdown // 激活接口

 廣域網口:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#int s0/0 // 進入配置廣域網口模式
Router(config-if)#ip address 202.202.240.2 255.255.255.0 // 配置 IP
Router(config-if)#no shutdown // 激活接口

 交通大學路由器 OSPF 路由配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#router ospf 1 // 啟用 OSPF 路由協議,進程號為1(可暫不理會進程號概念)
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0 // 自治域0中的屬於192.168.1.0/24網絡的所有主機(反向掩碼)參與 OSPF
Router(config-router)#network 202.202.240.0 0.0.0.255 area 0 // 自治域0中的屬於202.202.240.0/24網絡的所有主機(反向掩碼)參與 OSPF

 重慶大學路由器 OSPF 路由配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#router ospf 1 // 啟用 OSPF 路由協議,進程號為1
Router(config-router)#network 202.202.240.0 0.0.0.255 area 0 // 自治域0中的屬於202.202.240.0/24網絡的所有主機(反向掩碼)參與 OSPF
Router(config-router)#network 8.8.8.0 0.0.0.255 area 0 // 自治域0中的屬於8.8.8.0/24網絡的所有主機(反向掩碼)參與 OSPF

此時,這些 PC 能全部相互 ping 通!如在交通大學內部使用 PC0(192.168.1.2)來 ping 重慶大學的PC2(8.8.8.2)應該成功。

下面我們將重慶大學的路由器看著 Internet 中的骨幹路由器,那麼這些路由器將不會轉發內部/私有 IP 地址的包(直接丟弃)。我們通過在重慶大學路由器上實施訪問控制 ACL ,即丟弃來自交通大學(私有 IP 地址)的包來模擬這個丟包的過程。

重慶大學路由器丟包的配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#access-list 1 deny 192.168.1.0 0.0.0.255 // 創建 ACL 1,丟弃/不轉發來自 192.168.1.0/24 網絡的所有包
Router(config)#access-list 1 permit any // 添加 ACL 1 的規則,轉發其它所有網絡的包
Router(config)#int s0/0 // 配置廣域網口
Router(config-if)#ip access-group 1 in // 在廣域網口上對進來的包實施 ACL 1 中的規則,實際就是廣域網口如果收到來自 192.168.1.0/24 IP的包即丟弃

此時,再使用交通大學內部的 PC0(192.168.1.2)來 ping 重慶大學的 PC2(8.8.8.2)就不成功了,會顯示目的主機不可到達信息 

下面,我們就開始實施 PAT。即:我們將會在交通大學路由器的出口上將內部/私有 IP 地址轉換為外部/公開 IP,從而包的源 IP 發生了改變,就不會被重慶大學路由器丟弃,因此網絡連通。

交通大學路由器 PAT 配置:

Router>en // 從普通模式進入特權模式
Router#conf t // 進入全局配置模式
Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255 // 創建 ACL 1,允許來自 192.168.1.0/24 網絡的所有包
Router(config)#ip nat inside source list 1 interface s0/0 overload // 來自於 ACL 中的 IP 將在廣域網口實施 PAT
Router(config)#int f0/0 // 配置以太網口
Router(config-if)#ip nat inside // 配置以太網口為 PAT 的內部
Router(config)#int s0/0 // 配置廣域網口
Router(config-if)#ip nat outside // 配置廣域網口為 PAT 的外部

 現在,再次使用交通大學內部的 PC0(192.168.1.2)來 ping 重慶大學的PC2(8.8.8.2)則OK。

虛擬局域網 VLAN

交換機 VLAN 配置:

Switch>en
Switch#conf t
Switch(config)#vlan 10 // 創建 id 為 10 的 VLAN(缺省的,交換機所有接口都屬於VLAN 1,不能使用)
Switch(config-vlan)#name computer // 設置 VLAN 的別名
Switch(config-vlan)#exit
Switch(config)#int vlan 10 // 該 VLAN 為一個子網,設置其 IP,作為該子網網關
Switch(config-if)#ip address 192.168.0.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#vlan 20 // 創建 id 為 20 的 VLAN
Switch(config-vlan)#name communication //設置別名
Switch(config-vlan)#exit
Switch(config)#int vlan 20
Switch(config-if)#ip addr 192.168.1.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#vlan 30 // 創建 id 為 20 的 VLAN
Switch(config-vlan)#name electronic // 設置別名
Switch(config-vlan)#exit
Switch(config)#int vlan 30
Switch(config-if)#ip add 192.168.2.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int range f0/1-8 // 成組配置接口(1-8)
Switch(config-if-range)#switchport mode access // 設置為存取模式
Switch(config-if-range)#switchport access vlan 10 // 劃歸到 VLAN 10 中
Switch(config-if-range)#exit
Switch(config)#int range f0/9-16
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#int range f0/17-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#^Z
Switch#show vlan // 查看 VLAN 的劃分情况

至此,在該交換機上我們就劃分了 3 個 VLAN(不包括缺省的 VLAN 1)。

各 VLAN 下 PC 的網絡配置及連接的交換機接口如下錶:

 

機器名

連接的接口

所屬VLAN

IP

子網掩碼

網關

PC0

F0/1

VLAN 10

192.168.0.2

255.255.255.0

192.168.0.1

PC1

F0/2

VLAN 10

192.168.0.3

255.255.255.0

192.168.0.1

PC2

F0/17

VLAN 30

192.168.2.2

255.255.255.0

192.168.2.1

PC3

F0/9

VLAN 20

192.168.1.2

255.255.255.0

192.168.1.1

PC4

F0/10

VLAN 20

192.168.1.3

255.255.255.0

192.168.1.1

PC5

F0/18

VLAN 30

192.168.2.3

255.255.255.0

192.168.2.1

PC6

F0/19

VLAN 30

192.168.2.4

255.255.255.0

192.168.2.1

虛擬局域網管理 VTP

VTP(VLAN Trunk Protocol)即 VLAN 中繼協議。VTP 通過 ISL 幀或 Cisco 私有 DTP 幀(可查閱相關資料了解)保持 VLAN 配置統一性,也被稱為虛擬局域網幹道協議,它是思科私有協議。 VTP 統一管理、增加、删除、調整VLAN,自動地將信息向網絡中其它的交換機廣播。

此外,VTP 减小了那些可能導致安全問題的配置,只要在 VTP Server 做相應設置,VTP Client 會自動學習 VTP Server 上的 VLAN 信息。

目前該網絡都屬於 VLAN 1,也即這些 PC 是可以相互通信的。前面說過,無論對於性能、管理還是安全等而言,現實中我們必須進行 VLAN 劃分。

現在我們的要求是:新建兩個 VLAN,然後讓 PC0 和 PC1 屬於 VLAN 2,PC1 和 PC3 屬於 VLAN 3

我們將在核心交換機 3560上進行如下工作:

  1. 設置為 server 模式,VTP 域為 cqjtu
  2. 新建 VLAN 2,網絡號 192.168.1.0/24,網關 192.168.1.1
  3. 新建 VLAN 3,網絡號 192.168.2.0/24,網關 192.168.2.1

3560 VTP Server 配置:

Switch>en
Switch#conf t
Switch(config)#hostname 3560 // 更改交換機名稱(可選)
3560(config)#vtp domain cqjtu // 設置 VTP 域名稱為 cqjtu
3560(config)#vtp mode server // 設置其為 VTP 服務器模式
3560(config)#vlan 2 // 新建VLAN 2
3560(config-vlan)#name computer // 設置 VLAN 2 的別名(可選)
3560(config-vlan)#exit
3560(config)#vlan 3 // 再建 VLAN 3
3560(config-vlan)#name communication //設置 VLAN 2 的別名(可選)
3560(config-vlan)#exit
3560(config)#int vlan 2 // 配置接口 VLAN 2,它將是該子網(左邊)的網關
3560(config-if)#ip address 192.168.1.1 255.255.255.0
3560(config-if)#exit
3560(config)#int vlan 3 // 配置接口 VLAN 3,它將是該子網(右邊)的網關
3560(config-if)#ip address 192.168.2.1 255.255.255.0

 

我們將在左邊交換機 2960A 上進行如下工作:

  1. 加入名為 cqjtu 的 VTP 域
  2. 配置與核心交換機 3560 連接的千兆接口 g0/1 為 trunk 模式
  3. 將接口 f0/1 劃分到 VLAN 2 中
  4. 將接口 f0/2 劃分到 VLAN 3 中

2960A(左邊) VTP Client 配置:

Switch>en
Switch#conf t
Switch(config)#hostname 2960A // 更改交換機名稱(可選)
2960A(config)#vtp domain cqjtu // 加入名為 cqjtu 的 VTP 域
2960A(config)#vtp mode client // 設置模式為 VTP 客戶
2960A(config)#int g0/1 // 配置與核心交換機 3560 連接的 g0/1 千兆接口
2960A(config-if)#switchport mode trunk // 設置該接口為中繼(trunk)模式
2960A(config-if)#switchport trunk allowed vlan all // 允許為所有的 VLAN 中繼
2960A(config-if)#exit
2960A(config)#int f0/1 // 配置接口 1
2960A(config-if)#switchport mode access // 設置該接口為正常訪問模式
2960A(config-if)#switchport access vlan 2 // 將接口劃分到 VLAN 2
2960A(config-if)#exit
2960A(config)#int f0/2 // 配置接口 2
2960A(config-if)#switchport mode access // 設置該接口為正常訪問模式
2960A(config-if)#switchport access vlan 3 // 將接口劃分到 VLAN 3

我們將在右邊交換機 2960B 上進行同樣的工作:

  1. 加入名為 cqjtu VTP 域
  2. 配置與核心交換機 3560 連接的千兆接口 g0/1 為 trunk 模式
  3. 將接口 f0/1 劃分到 VLAN 2 中
  4. 將接口 f0/2 劃分到 VLAN 3 中

2960B(右邊) VTP Client 配置:

 

witch>en
Switch#conf t
Switch(config)#hostname 2960B // 更改交換機名稱(可選)
2960B(config)#vtp domain cqjtu // 加入名為 cqjtu 的 VTP 域
2960B(config)#vtp mode client // 設置模式為 VTP 客戶
2960B(config)#int g0/1 // 配置與核心交換機 3560 連接的 g0/1 千兆接口
2960B(config-if)#switchport mode trunk // 設置該接口為中繼(trunk)模式
2960B(config-if)#switchport trunk allowed vlan all // 允許為所有的 VLAN 中繼
2960B(config-if)#exit
2960B(config)#int f0/1 // 配置接口 1
2960B(config-if)#switchport mode access // 設置該接口為正常訪問模式
2960B(config-if)#switchport access vlan 2 // 將接口劃分到 VLAN 2
2960B(config-if)#exit
2960B(config)#int f0/2 // 配置接口 2
2960B(config-if)#switchport mode access // 設置該接口為正常訪問模式
2960B(config-if)#switchport access vlan 3 // 將接口劃分到 VLAN 3

至此,各交換機配置完畢。 

各 PC 連接的交換機和接口以及網絡配置如下:

機器名

連接的交換機和接口

所屬VLAN

IP

子網掩碼

網關

PC0

2960A-F0/1

VLAN 2

192.168.1.2

255.255.255.0

192.168.1.1

PC1

2960A-F0/2

VLAN 3

192.168.2.2

255.255.255.0

192.168.2.1

PC2

2960B-F0/1

VLAN 2

192.168.1.3

255.255.255.0

192.168.1.1

PC3

2960B-F0/2

VLAN 3

192.168.2.3

255.255.255.0

192.168.2.1

至此,VTP 配置完成。同 VLAN 可以 ping 通,而不同 VLAN 不行(即使在同一交換機下,如從 PC0 到 PC1),且能够方便的統一規劃和管理。

VLAN 間的通信

VTP 只是給我們劃分和管理 VLAN 提供了方便,由上面的測試得知,目前我們仍然不能在 VLAN 間通信。

因為默認的,VLAN 間是不允許進行通信,此時我們需要所謂的獨臂路由器在 VLAN 間為其進行轉發!

我們使用的核心交換機 3560 是個 3 層交換機,可工作在網絡層,也稱路由交換機,即具有路由功能,能進行這種轉發操作。

3560 交換機配置:

3560>en
3560#conf t
3560(config)#int g0/1 // 配置連接左邊 2960A 交換機的接口
3560(config-if)#switchport trunk encapsulation dot1q // 封裝 VLAN 協議
3560(config-if)#switchport mode trunk // 設置為中繼模式
3560(config-if)#switchport trunk allowed vlan all // 在所有 VLAN 間轉發
3560(config-if)#exit
3560(config)#int g0/2 // 配置連接右邊 2960B 交換機的接口
3560(config-if)#switchport trunk encapsulation dot1q //封裝 VLAN 協議
3560(config-if)#switchport mode trunk // 設置為中繼模式
3560(config-if)#switchport trunk allowed vlan all // 在所有 VLAN 間轉發
3560(config-if)#exit
3560(config)#ip routing // 啟用路由轉發功能

DHCP、DNS及Web服務器簡單配置

 構建如下簡單的拓撲。

 

該拓撲中,服務器及客戶機都連在同一交換機上。為簡單起見,服務器 Server-PT 同時作為 DHCP、DNS 以及 Web 服務器,各客戶機無需配置,將自動獲取網絡配置。

點擊 CPT 拓撲圖中的 Server 圖標,設置其靜態 IP 地址為 19.89.6.4/24,然後選擇 Service 進行如下相關配置:

機器名

配置項目

說明

Server

HTTP

開啟即可

Server

DNS

19.89.6.4:www.google.com、www.baidu.com

Server

DHCP

地址池開始地址:19.89.6.10/24,並返回DNS地址

PC

網絡配置

自動獲取

版权声明:本文为[m0_62588424]所创,转载请带上原文链接,感谢。 https://gsmany.com/2022/01/202201072246467231.html