python-App自動化測試框架——手機模擬器adb版本與環境中adb版本不一致導致運行失敗

覓遠 2022-01-07 07:09:07 阅读数:615

python-app python app 框架 adb

問題

輸入adb devices查看連接的設備時報下面的錯誤 

在使用appium配置完手機模擬器參數的時候會出現,點擊開始運行的時候連接的設備會被斷開,這時可以檢查環境中的adb版本和模擬器中adb版本是否一致,檢查方法:

環境配置中adb版本:已經配置了path環境變量,所以之間在命令行執行adb --version

模擬器中的adb版本:切換到模擬器bin目錄nox_adb.exe所在的文件夾下,cd  D:\夜神模擬器\Nox\bin ,輸入命令 nox_adb --version 查看

 

解决方法

版本不一致的解决方法:關閉模擬器後,把模擬器下的nox_adb.exe文件删除或者備份後,將環境中的adb.exe文件複制一份到模擬器bin目錄下,並改名為nox_adb.exe即可,然後重啟模擬器進行連接

版权声明:本文为[覓遠]所创,转载请带上原文链接,感谢。 https://gsmany.com/2022/01/202201070709074301.html